Problem with Smart Sending

Discussions about AccuTracking software and web tracking.
Post Reply
ddover

Problem with Smart Sending

Post by ddover »

I have recently started to use AccuTracking. I have an Android phone wired directly to a charger in my vehicle. I plan to leave it running continuously.

I think Smart Sending is a great feature. Perhaps I have not completely understood how it is supposed to work, but I am having the following problems:

1. The phone is not sending out a heartbeat. I understood that it should transmit its location every 30 minutes, but when the vehicle is stationary, there are no transmissions at all. I see the following sequence of messages on the screen
- GPS sleeping
- Waking up GPS...
- Smart sending triggered

My settings are as follows:
- sending interval 1 minute
- smart sending enabled
- hot GPS disabled
- auto interval disabled
- auto start on powerup enabled
- cache size 1000
- password disabled

2. Related to the above, when the vehicle becomes stationary, it does not send out an initial message indicating the stationary location, so for example when the vehicle is parked in my garage, the last shown location could be a block away. As I will be driving into an area where car-jacking is common, it's important to know exactly where the vehicle is located.

If I then move the car, the transmissions resume and show the track properly.

3. I drove into an area that was outside of my cell provider's coverage area. Only the 1st of the cached locations was transmitted when coverage resumed, not the entire track, even though i have a cache size of 1000.

I think this is a great product and I hope this issues can be resolved.

Thank you.
Dan

ATSupport
AccuTracking Staff
Posts: 1882
Joined: Tue Jan 27, 2004 4:36 pm
Contact:

Re: Problem with Smart Sending

Post by ATSupport »

Problem 1 & 2 are likely caused by the same issue - poor sky view - so that the phone cannot acquire your position. You did mention it's in the garage so that might be the issue.

Problem 3 sounds like a bug and we are looking into that. What's your phone model and Android OS version please?
AccuTracking Support
support(at)accutracking.com

ddover

Re: Problem with Smart Sending

Post by ddover »

Thanks for the quick response.

The phone is an LG GT540 (unlocked), firmware version 2.1-update 1.

To check whether poor sky view is causing problems 1 & 2, I drove the car around the block, then parked in the driveway where there is a good sky view. The same problems occurred - no update for the stationary position and no heartbeat after 64 minutes..

The google map on the phone shows the proper location which seems to indicate the GPS is functioning.

Dan

ATSupport
AccuTracking Staff
Posts: 1882
Joined: Tue Jan 27, 2004 4:36 pm
Contact:

Re: Problem with Smart Sending

Post by ATSupport »

Sorry but I forgot to ask, what's the AccuTracking version installed on your phone?
AccuTracking Support
support(at)accutracking.com

Guest

Re: Problem with Smart Sending

Post by Guest »

Accutracking version 23...

Dan

ddover

Re: Problem with Smart Sending

Post by ddover »

Strangely enough, it sent one position report from the garage last night, 6 hrs and 12 minutes after the previous report one block away. Nothing since.

ATSupport
AccuTracking Staff
Posts: 1882
Joined: Tue Jan 27, 2004 4:36 pm
Contact:

Re: Problem with Smart Sending

Post by ATSupport »

ddover wrote:Strangely enough, it sent one position report from the garage last night, 6 hrs and 12 minutes after the previous report one block away. Nothing since.
This makes me believe it's the GPS reception issue.

There's a new v3.7.0 (version number 24) you should use. The new version uses network locations when GPS is not available so it'll surely give you more readings.
AccuTracking Support
support(at)accutracking.com

ATSupport
AccuTracking Staff
Posts: 1882
Joined: Tue Jan 27, 2004 4:36 pm
Contact:

Re: Problem with Smart Sending

Post by ATSupport »

ddover wrote:3. I drove into an area that was outside of my cell provider's coverage area. Only the 1st of the cached locations was transmitted when coverage resumed, not the entire track, even though i have a cache size of 1000.
Dan,

We have just released v3.7.2 (version number 26) targeting the problem 3 you reported. We cannot reproduce the issue but added some info to better assist troubleshooting. It now displays the current number of records in the cache on the phone screen so you can get an idea of whether caching is working as expected.

Please install the new version and pay attention to the cache info on the screen. Let me know if cached data are being sent when you move from non-network area back to coverage. Thanks for sending us the feedback!
AccuTracking Support
support(at)accutracking.com

ddover

Re: Problem with Smart Sending

Post by ddover »

Thanks very much for responding so quickly to my concerns. As it happens, I had an opportunity to be outside of the coverage area yesterday, so I was able to do some further testing.

1. Heartbeat. I tested the heartbeat function in several locations with a clear skyview. In my configuration, it is definitely not sending out an updated report every 30 minutes.

2. Initial location report when stationary. I am getting this report, except when the vehicle is in the garage, which confirms your explanation about sky view. Thank you.

3. Caching. Mixed results. As I left the coverage area, it appeared to cache two location reports, then apparently got a connection for one report, then lost the connection altogether. There were approximately 42 cached records shown on the screen status as I returned to coverage. (I can't be exact since I was driving.) The cached records were then transmitted, one by one, as the cached records total decremented. So far, so good.

However, when I look at the history online, it appears to have transmitted only 33 records. The records between 13:52 and 14:19 when I returned to coverage were lost. The track then continues normally until I returned home.


I just want to say that I think this is a great program and much superior to others I have tried. The problems I have outlined are relatively minor, although still important to me. In order of priority I would put the heartbeat first, then the caching.

Thanks for your attention to my problems.

Dan

ATSupport
AccuTracking Staff
Posts: 1882
Joined: Tue Jan 27, 2004 4:36 pm
Contact:

Re: Problem with Smart Sending

Post by ATSupport »

We are looking into the heartbeat issue. Thanks again for the update.
AccuTracking Support
support(at)accutracking.com

Post Reply