When HotGPS is enabled, last position is not reported

Post a reply


In an effort to prevent automatic submissions, we require that you complete the following challenge.
Smilies
:D :) :( :o :shock: :? 8) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :wink: :!: :?: :idea: :arrow: :| :mrgreen:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: When HotGPS is enabled, last position is not reported

Re: When HotGPS is enabled, last position is not reported

by hutch109 » Sun Apr 06, 2008 5:10 am

Well I am glad to hear that it appears to have solved your issues. If anything changes with further testing - post an update.

Eric

Re: When HotGPS is enabled, last position is not reported

by Guest » Sun Apr 06, 2008 2:30 am

Thanks for the responses.

I tested the workaround provided by hutch109 and it works, but with an unexpected behavior. I set one of the units with HotGPS on and Smart Sending in off.

As expected, it got a fix during the first 5 minutes interval. When the car stopped, the unit reported the stop after the interval as well. Then, surprisingly, instead of reporting redundant data every 5 minutes as I would expect, according to the website it only sent data every heartbeat... almost identically to the unit with the smart sending on and hotGPS off.

I see no point in to investigate further, as the unit works as I need, and my Mappoint application will be happy without the extra clutter of the redundant data.

Thanks again.

Re: When HotGPS is enabled, last position is not reported

by ATSupport » Sat Apr 05, 2008 2:35 pm

I agree with hutch109. :)

Re: When HotGPS is enabled, last position is not reported

by hutch109 » Sat Apr 05, 2008 12:29 pm

Try turning "smart sending" off - does that fix your issue? For the most accurate info - keep it off.

Smart sending has a "window" that it takes before reporting a location - so you could be in the area, but not outside of zone, needed for the new update.

That make sense?

And yes, you will see those problems with a car that has been garaged overnight, and with the phone on. For another test, power the phones on/off before you leave the garage - and keep everything else the same. That fix it?

And as a side note, if your running the unit on batteries, you probably won't be able to do that with hot GPS on - wait, you can do that, but only for a short time before the batteries go dead... Its quite the power hog to keep the GPS active all the time - and you really don't get that big of advantage.

Eric

When HotGPS is enabled, last position is not reported

by Guest » Sat Apr 05, 2008 11:41 am

I have been testing 2 i425 units (with v3.3.1) installed in the same mobile. Both with the following settings:

- Send Interval: 5 minutes
- Smart Sending: on
- Auto Interval: on
- Password protect: set

One of the units has HotGPS on and the other has it off. All other checkboxes are clear. I have interchanged the position in the car, and the HotGPS setting between the two units, to discard location/hardware failures. The car is garaged overnight.

Consistently, the unit with HotGPS on is able to get a fix before the initial 5 minutes, and the phone is able to report its location accordingly. The unit with the HotGPS off, normally takes two to five cycles to get a fix, and sometimes for short trips (less than 20 minutes), it even does not report any tracking data, so HotGPS on is a must have in my case.

When the mobile arrives to destination (clear sky view, full GPS and cellular signal readings), the unit with the HotGPS off reports it last position as stopped almost immediately, while the unit with HotGPS on does not report anything until the heartbeat timeout of 30 minutes has passed, and sometimes longer. Stops shorter than the timeout are not detected by the unit with HotGPS on, as it reports the next crumb as if it were part of the last route. This has happened a 100% of the times.

Am I missing something in the settings?

Thanks in advance.

Top